Home > Return Code > External Program Failed Msbuild.exe (return Code Was 1)

External Program Failed Msbuild.exe (return Code Was 1)

Contents

share|improve this answer answered Sep 29 '11 at 1:17 Omar 1,123915 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign Kind regards, K BBhavani. project xyz has not finished. I have actually just tired loading up the VS IDE on the build server as well and tried a manual build on there, and it still fails, so there is obviously Check This Out

I'm having the same problem. compile: [mkdir] Creating directory 'C:\Downloads\image_manipulation\classes'. The only message appears in the log ( which is generated by /log switch of devenv command) is : ----Rebuild All started:Project:DWRAPPER, Configuration:BuildWithPortalSVC Win 32- ----Rebuild All started:Project:XYZ, Configuration:BuildWithPortalSVC Win 32--- All Rights Reserved. check over here

External Program Failed Msbuild.exe (return Code Was 1)

Re: [NAnt-users] VS2010 devenv command from NAnt fails From: Bevan Arps - 2013-05-24 10:23:19 Attachments: Message as HTML As I recall (it's been a while), devenv.exe is what you run To do that open your solution in VS, open project properties for helloW and set General-->Compiler and Environment Settings property to "Microsoft Visual C++ Compiler (cl.exe)" for Release configuration. Subject: RE: [NAnt-users] VS2010 devenv command from NAnt fails Hi Bevan, Thank you for the quick response. Secondly, have you considered using MSBuild?

If you are not the intended recipient, please do not use or disseminate the information, notify the sender and delete it from your system. Top Log in to post comments Akhil K. The only message appears in the log ( which is generated by /log switch of devenv command) is : ----Rebuild All started:Project:DWRAPPER, Configuration:BuildWithPortalSVC Win 32- ----Rebuild All started:Project:XYZ, Configuration:BuildWithPortalSVC Win 32--- C:\Documents and Settings\Sakina>cd Desktop C:\Documents and Settings\Sakina\Desktop>nant compile The system cannot find the path specified.

Please let me know. Tel # +91 080 6624 3452 The information contained in this email has been classified: ( ) Larsen & Toubro Limited - General Business (X) Larsen &Toubro Limited - Internal Use One last thought: Deployment projects are deprecated in Visual Studio 2010 - and they’re not supported at all by Visual Studio 2012. Please help hfrmobile commented May 16, 2013 You're welcome!

did you try? The only message appears in the log ( which is generated by /log switch of devenv command) is : ----Rebuild All started:Project:DWRAPPER, Configuration:BuildWithPortalSVC Win 32- ----Rebuild All started:Project:XYZ, Configuration:BuildWithPortalSVC Win 32--- Also running nunit or msunit test when building a project/solution. Re: [NAnt-users] VS2010 devenv command from NAnt fails From: Nikhil Gupta - 2013-05-24 08:47:24 Attachments: Message as HTML Any specific reason you are using devenv?

Nant Exec Cmd

Below are the details: > > > > · We migrated our project from Visual studio 2005 to Visual > studio 2010. > > · Post migration, we are seeing build Later changed to devenv.exe. External Program Failed Msbuild.exe (return Code Was 1) Below are the details: * We migrated our project from Visual studio 2005 to Visual studio 2010. * Post migration, we are seeing build issue in the build server machine. Nant External Program Failed Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox.

Thanks, Vadim. his comment is here If you don't specify an extension, the shell looks for possible programs to run by trying various extensions. If you have received this communication in error, please immediately notify the sender by reply e-mail and destroy this communication. Subject: RE: [NAnt-users] VS2010 devenv command from NAnt fails Hi Bevan, Thank you for the quick response.

If it didn't, please post the NCover output from NAnt so that we can determine what went wrong. Tel # +91 080 6624 3452 The information contained in this email has been classified: ( ) Larsen & Toubro Limited - General Business (X) Larsen &Toubro Limited - Internal Use The only message appears in the log ( which is generated by /log switch of devenv command) is : ----Rebuild All started:Project:DWRAPPER, Configuration:BuildWithPortalSVC Win 32- ----Rebuild All started:Project:XYZ, Configuration:BuildWithPortalSVC Win 32--- this contact form Hi Bevan, Looks like devenv.com resolved thee issue.

Some background. Jim Dempsey www.quickthreadprogramming.com Top Log in to post comments Jennifer J. (Intel) Tue, 06/11/2013 - 11:31 I'm wondering if "devenv /setup" would help. I couldn't reproduce the issue with IDE 11.1.

Same results.

Just click to run the setup, it will detect that VS is already installed and try repair. Prove that the normalizer of the subgroup is the subgroup is itself What would be your next deduction in this game of Minesweeper? I never tried to automate Visual Studio 2005, so it’s possible that using devenv.EXE worked just fine for that version; for later versions, it doesn’t. I #think# it uses this order: bat, cmd, exe, com.

Kind regards, K BBhavani. Unless you’re doing something not supported by MSBuild (like a .vdproj msi deployment project), MSBuild can be a more reliable choice. Subject: RE: [NAnt-users] VS2010 devenv command from NAnt fails Hi Bevan, Thank you for the quick response. http://itivityglobal.com/return-code/vsam-catalog-return-code-is-8-reason-code-is-igg0cleg-42.html To: Bevan Arps; [email protected]

What am I doing wrong? If this is a problem with Intel C++ compiler ( let's assume it / Not proven ) then more technical details or a reproducer are needed. there is no other error message that helps to find > out what is happening during build of VS 2010 with NAnt. Re: [NAnt-users] VS2010 devenv command from NAnt fails From: - 2013-05-25 00:28:56 Attachments: Message as HTML Devenv.Com is designed for use for batch automation; Devenv.Exe is how the interactive IDE

What does return code 1 mean?

RE: External Program Failed.. Secondly, have you considered using MSBuild? the reported issue only shows up during command line build... Firstly, are you executing devenv.com or devenv.exe ?

External Program Failed..